鍍金池/ 教程/ Android/ 使用 Eclipse
下載源碼
根據設備構建
Git 資源
構建系統
Android 平臺 64 位構建指導
初始化編譯環(huán)境
Android 源代碼
品牌指南
已知的問(wèn)題
Repo 命令手冊
構建內核
Bug 的生命周期
代碼主線(xiàn)、分支和版本
使用 Eclipse
提交補丁
下載與構建
參與
項目角色
補丁的生命周期
提交 Bugs
關(guān)于代碼風(fēng)格的指導
開(kāi)發(fā)
代碼名稱(chēng),標簽和版本號

使用 Eclipse

本文將幫助您為 Android 平臺開(kāi)發(fā)建立 Eclipse IDE。

注意:如果您正在尋找如何使用 Eclipse 開(kāi)發(fā) Android 上運行的應用程序的資料,那么這不是您要找的頁(yè)面。你也許會(huì )發(fā)現 the Eclipse page on developer.android.com 頁(yè)面更加有用。

基本設置

首先,重要的是要確保常規 Android 開(kāi)發(fā)系統的設置。

cd /path/to/android/root   
make

重要提示:你將仍然使用 make 建立你的文件,實(shí)際運行(在模擬器上或者設備上)。你將使用 Eclipse 來(lái)編輯文件并且驗證它們的編譯,但是當你想要運行某些東西時(shí)你需要確保你的文件保存在 Eclipse 里,并且在命令行(shell)里運行 make。Eclipse 的建立只是為了檢查錯誤。

Eclipse 需要一個(gè)目錄列表去搜索 Java 文件。這個(gè)被稱(chēng)為“Java Build Path(Java 構建路徑)”,還能夠設置到 .classpath 文件。我們有一個(gè)示例版本讓你開(kāi)始。

cd /path/to/android/root   
cp development/ide/eclipse/.classpath .
chmod u+w .classpath

如果必要的話(huà),現在可以編輯復制 .classpath。

增加 Eclipse 的內存設置

Android 項目(所占空間)非常的大以致有時(shí) Eclipse 的 Java VM 在運行編譯時(shí)內存不足。而編輯 eclipse.ini 文件就可以避免這個(gè)問(wèn)題。在 Apple OSX 上,eclipse.ini 文件是位于

/Applications/eclipse/Eclipse.app/Contents/MacOS/eclipse.ini

內存相關(guān)的默認設置(如 Eclipse 3.4)

 -Xms40m  
 -Xmx256m  
 -XX:MaxPermSize=256m

為 Android 開(kāi)發(fā)的建議設置是:

 -Xms128m 
 -Xmx512m 
 -XX:MaxPermSize=256m

這些設置是將 Eclipse 的 Java 堆的最小值設為 128 MB,最大值設為 512 MB,并且默認永久代的最大值為 256 MB。

現在啟動(dòng) Eclipse:

eclipse

創(chuàng )建一個(gè)項目

現在為 Android 開(kāi)發(fā)創(chuàng )建一個(gè)項目:

  1. 如果 Eclipse 要求你選擇一個(gè)工作區的位置,選擇默認。
  2. 如果你有一個(gè)“歡迎”屏幕,關(guān)閉它顯示到 Java 視圖。
  3. 文件(File) > 新建(New) > Java 項目(Java Project)
  4. 選擇一個(gè)項目名稱(chēng),“android”或者任何你喜歡的名稱(chēng)。
  5. 取消使用默認位置,輸入路徑到 Android 根目錄,然后點(diǎn)擊 Finish。
  6. 等待建立項目的時(shí)候。(你會(huì )看到一個(gè)微妙的進(jìn)度表在右下角)

一旦項目工作區創(chuàng )建,Eclipse 也應當開(kāi)始構建。從理論上講,它的建立應該是沒(méi)有錯誤的,你應該準備好開(kāi)始啟動(dòng)。如果有必要,取消選擇再重新選擇項目自動(dòng)構建(Project Build Automatically)以強制重建。

注意:Eclipse 有時(shí)會(huì )添加一個(gè) import android.R 聲明在你文件的頂部以使用資源,特別是當你要求 Eclipse 分類(lèi)或以其他方式管理導入包(imports)。這將導致你的構造被破壞。要留心找到那些錯誤的導入聲明并刪除掉它們。

當你同步時(shí)

每次你同步 Repo,或者以其他方式改變 Eclipse 外部的文件(特別是 .classpath)時(shí),你需要更新 Eclipse 視圖的以下東西:

  1. 窗口(Windows) > 顯示視圖(Show View)> 導航(Navigator)
  2. 在導航(Navigator)中,右鍵單擊項目名稱(chēng)
  3. 點(diǎn)擊右鍵菜單中的刷新(Refresh)。

添加 Apps到構建路徑中

默認的 .classpath 包括核心系統的來(lái)源和一組 APP 的例子,但也許并不包括你想要的特定的 APP。添加一個(gè) APP,你必須添加 APP 的源目錄。需要在 Eclipse 里面完成這些:

  1. 項目(Project)> 屬性(Properties)
  2. 選擇左邊菜單上的 “Java Build Path(Java 構建路徑)”上。
  3. 選擇 “Source” 選項卡。
  4. 點(diǎn)擊“Add Folder…(添加文件夾…)”
  5. 添加你的 APP 的 src 目錄下。
  6. 點(diǎn)擊 OK。

當你完后,你應該可以看到 “source folder” 路徑在列表中如下顯示:

android/packages/apps/YOURAPP/src

根據你所包含的 APP,你可能也需要包含 android/dalvik/libcore 下的 othersrc/main/java 目錄。如果你發(fā)現你不能在默認設置下構建的時(shí)候你就用這個(gè)方法。

Eclipse 格式化

你可以導入文件到 development/ide/eclipse 里面使得 Eclipse 跟隨 Android 的樣式規則。

  1. 選擇窗口(Windows)> 參數選擇(Preferences)> Java > 代碼風(fēng)格(Code Style)。
  2. 使用格式化(Formatter)> 導入 android-formatting.xml。
  3. 整理導入包 (Imports) > 導入 android.importorder。

使用 Eclipse 調試模擬器

你也可以使用 Eclipse 通過(guò)單步調試代碼去調試模擬器。首先,開(kāi)始運行模擬器:

cd /path/to/android/root 
. build/envsetup.sh 
lunch 1    
make       
emulator

如果模擬器正在運行,你可以看見(jiàn)一張手機的圖片。

在另一個(gè)命令行,啟動(dòng) DDMS(Dalvik 虛擬機調試管理器):

cd /path/to/android/root 
ddms

你應該看到一個(gè) splufty 調試控制臺。

現在,在 Eclipse中,您可以連接到模擬器:

  1. 運行(Run)> 打開(kāi)調試對話(huà)框…(Open Debug Dialog…)
  2. 右鍵單擊 “Remote Java Application(選擇遠程調試)”,選擇 “New(新建)”。
  3. 選擇一個(gè)你喜歡的名字,例如“android-debug”或任何東西。
  4. 將“Project”設置為你的項目名稱(chēng)。
  5. 主機(Host)依舊設置為“l(fā)ocalhost”,但端口(Port)更改為 8700。
  6. 點(diǎn)擊“Debug(調試)”按鈕,這樣就應該準備就緒了。

需要注意的是端口 8700 連接到任何的進(jìn)程都是在目前 DDMS 控制臺選擇的,所以你需要確保 DDMS 已經(jīng)選擇你想要調試的進(jìn)程。

你可能需要打開(kāi)調試(Debug)視圖(在“Java”視圖圖標的右上角,點(diǎn)擊的“Open Perspective(打開(kāi)視圖)” 的小圖標然后選擇“Debug(調試)”)。一旦你做了這些,你應該可以看到一個(gè)線(xiàn)程的列表;如果你選擇一個(gè)(線(xiàn)程)并且中斷它(通過(guò)點(diǎn)擊“pause(暫停)”圖標),那么它應該顯示堆棧跟蹤,源文件和執行路線(xiàn)。斷點(diǎn)和諸如此類(lèi)的東西都應該在工作。

擴展材料

Mac 系統的蘋(píng)果鍵替換 Ctrl 鍵

快捷鍵 功能
Ctrl-Shift-o 導入所有需要的包
Ctrl-Shift-t 按名稱(chēng)加載類(lèi)
Ctrl-Shift-r 按名稱(chēng)加載非資源類(lèi)
Ctrl-1 快速修復
Ctrl-e 最近查看的文件
Ctrl-space 自動(dòng)完成
Shift-Alt-r 重構:重命名
Shift-Alt-v 重構:移動(dòng)

Eclipse 不能正常運行時(shí),該怎么做?

首先確認:

  • 你準確地按照這個(gè)網(wǎng)頁(yè)的說(shuō)明去執行。
  • 你的問(wèn)題(Problems)視圖沒(méi)有顯示任何錯誤。
  • 你的應用程序遵從包/目錄的構造。

如果你仍然有問(wèn)題,請聯(lián)系其中一個(gè) Android 社區電子郵箱列表或 IRC 通道。

上一篇:參與下一篇:初始化編譯環(huán)境